hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yi Liu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11789) NPE in TestCryptoStreamsWithOpensslAesCtrCryptoCodec
Date Wed, 08 Apr 2015 06:18:13 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11789?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14484799#comment-14484799
] 

Yi Liu commented on HADOOP-11789:
---------------------------------

Colin, if {{-Pnative}} is set, but the os doesn't have a correct version of OpenSSL, then
we should make the test failed? Could we test the crypto streams with OpensslAesCtrCryptoCodec
only if correct Openssl is loaded? Otherwise people will still see the failure in the environment
without correct OpenSSL.

> NPE in TestCryptoStreamsWithOpensslAesCtrCryptoCodec 
> -----------------------------------------------------
>
>                 Key: HADOOP-11789
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11789
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 3.0.0, 2.8.0
>         Environment: ASF Jenkins
>            Reporter: Steve Loughran
>            Assignee: Yi Liu
>         Attachments: HADOOP-11789.001.patch
>
>
> NPE surfacing in {{TestCryptoStreamsWithOpensslAesCtrCryptoCodec}} on  Jenkins



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message