hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11875) [JDK8] Renaming _ as a one-character identifier to another identifier
Date Thu, 28 Jan 2016 12:18:40 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11875?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15121306#comment-15121306
] 

Steve Loughran commented on HADOOP-11875:
-----------------------------------------

This is going to be fun in Hamlet. It not only has the method {{_()}}, it has the interface
{{ _ }} too.
We'll have to do something like

# define a new method and interface, {{__}}
# tag the old one as deprecated "will be removed for Java 9"
# adopt the new one while retaining the old one for compatibility —for now


> [JDK8] Renaming _ as a one-character identifier to another identifier
> ---------------------------------------------------------------------
>
>                 Key: HADOOP-11875
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11875
>             Project: Hadoop Common
>          Issue Type: Bug
>            Reporter: Tsuyoshi Ozawa
>              Labels: newbie
>         Attachments: build_error_dump.txt
>
>
> From JDK8, _ as a one-character identifier is disallowed. Currently Web UI uses it. We
should fix them to compile with JDK8. https://bugs.openjdk.java.net/browse/JDK-8061549



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message