hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marco Zühlke (JIRA) <j...@apache.org>
Subject [jira] [Commented] (HADOOP-11875) [JDK8] Renaming _ as a one-character identifier to another identifier
Date Fri, 08 Jan 2016 16:19:39 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-11875?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15089439#comment-15089439

Marco Zühlke commented on HADOOP-11875:

It is a compile-time error if a lambda parameter has the name _ (that is, a single underscore

The use of the variable name _ in any context is discouraged. Future versions of the Java
programming language may reserve this name as a keyword and/or give it special semantics.


So for the time being only a warning.

> [JDK8] Renaming _ as a one-character identifier to another identifier
> ---------------------------------------------------------------------
>                 Key: HADOOP-11875
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11875
>             Project: Hadoop Common
>          Issue Type: Bug
>            Reporter: Tsuyoshi Ozawa
>              Labels: newbie
> From JDK8, _ as a one-character identifier is disallowed. Currently Web UI uses it. We
should fix them to compile with JDK8. https://bugs.openjdk.java.net/browse/JDK-8061549

This message was sent by Atlassian JIRA

View raw message