hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kai Zheng (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-13061) Refactor erasure coders
Date Thu, 11 Aug 2016 05:31:20 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-13061?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15416578#comment-15416578

Kai Zheng commented on HADOOP-13061:

Hi Kai,

Looks like you misunderstood what I meant. I meant to introduce a new class say {{ErasureCodecOptions}}.
Could we avoid changing into HDFS side, since HDFS is still using the raw coder APIs.

And also, would you help clean the following block in {{CommonConfigurationKeys}}? It's bad
to mess the common place (not caused by this). Maybe the default values could be defined in
{{CoderUtil}} place.
import org.apache.hadoop.io.erasurecode.codec.HHXORErasureCodecFactory;
import org.apache.hadoop.io.erasurecode.codec.RSErasureCodecFactory;
import org.apache.hadoop.io.erasurecode.codec.XORErasureCodecFactory;
import org.apache.hadoop.io.erasurecode.rawcoder.RSRawErasureCoderFactory;
import org.apache.hadoop.io.erasurecode.rawcoder.RSRawErasureCoderFactoryLegacy;
import org.apache.hadoop.io.erasurecode.rawcoder.XORRawErasureCoderFactory;

> Refactor erasure coders
> -----------------------
>                 Key: HADOOP-13061
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13061
>             Project: Hadoop Common
>          Issue Type: Sub-task
>            Reporter: Rui Li
>            Assignee: Kai Sasaki
>         Attachments: HADOOP-13061.01.patch, HADOOP-13061.02.patch, HADOOP-13061.03.patch,
HADOOP-13061.04.patch, HADOOP-13061.05.patch

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org

View raw message