hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kai Zheng (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-13061) Refactor erasure coders
Date Mon, 15 Aug 2016 09:38:20 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-13061?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15420788#comment-15420788
] 

Kai Zheng commented on HADOOP-13061:
------------------------------------

Thanks Kai for the update! Looks like more changes need to be made according to previous refactoring
thoughts and discussions.

1. Could we get rid of codec factories? They don't seem to be needed.
2. Could we change {{AbstractErasureCodec}}: 1) remove the interface {{ErasureCodec}}; 2)
remove the parent of Configured.
3. In AbstractErasureCodec, we could have both coderOptions and codecOptions as members. Please
refine the get/set methods accordingly.
4. I'm sorry, but could you move the new constants added to {{CoderUtil}} into {{CodecUtil}}?
This will help keep CoderUtil internal.


> Refactor erasure coders
> -----------------------
>
>                 Key: HADOOP-13061
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13061
>             Project: Hadoop Common
>          Issue Type: Sub-task
>            Reporter: Rui Li
>            Assignee: Kai Sasaki
>         Attachments: HADOOP-13061.01.patch, HADOOP-13061.02.patch, HADOOP-13061.03.patch,
HADOOP-13061.04.patch, HADOOP-13061.05.patch, HADOOP-13061.06.patch, HADOOP-13061.07.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message