hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vrushali C (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-13485) Log refactoring: method invocation should be replaced by variable in hadoop tools
Date Thu, 11 Aug 2016 16:06:20 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-13485?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Vrushali C updated HADOOP-13485:
--------------------------------
    Status: Patch Available  (was: Open)

> Log refactoring: method invocation should be replaced by variable in hadoop tools
> ---------------------------------------------------------------------------------
>
>                 Key: HADOOP-13485
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13485
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: tools
>    Affects Versions: 2.7.2
>            Reporter: Nemo Chen
>         Attachments: HADOOP-13485.001.patch
>
>
> Similar to the fix for HDFS-409. In file:
> hadoop-rel-release-2.7.2/hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java
> {code:borderStyle=solid}
> this.blockSize = conf.getLong(AZURE_BLOCK_SIZE_PROPERTY_NAME,
>         MAX_AZURE_BLOCK_SIZE);
> if (LOG.isDebugEnabled()) {
>     LOG.debug("NativeAzureFileSystem. Initializing.");
>     LOG.debug("  blockSize  = "
>           + conf.getLong(AZURE_BLOCK_SIZE_PROPERTY_NAME, MAX_AZURE_BLOCK_SIZE));
> }
> {code}
> For simplicity and readability, the {{conf.getLong(AZURE_BLOCK_SIZE_PROPERTY_NAME, MAX_AZURE_BLOCK_SIZE))}}
should be changed to {{this.blockSize}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message