hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Nauroth (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-13502) Rename/split fs.contract.is-blobstore flag used by contract tests.
Date Mon, 03 Oct 2016 18:54:20 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-13502?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Chris Nauroth updated HADOOP-13502:
    Attachment: HADOOP-13502-branch-2.001.patch

I'm attaching patch 001.  Summary:

* Introduced 2 new specific contract options: create-overwrites-directory and create-visibility-delayed.
* Deprecated the is-blobstore flag, but retained it in case file system implementations outside
the Hadoop source tree are using it.  (Side note: do we need to add audience and stability
annotations to the contract test classes?)
* Cleaned up a few minor JavaDoc omissions in {{ContractOptions}}.
* Updated contract XML configuration files to remove usage of is-blobstore for the actively
maintained file systems.  Notice that S3A adds create-visibility-delayed, but does not add
create-overwrites-directory.  That's because HADOOP-13188 recently changed the implementation
to avoid overwriting directories.

So far, I have tested by running all subclasses of {{AbstractContractCreateTest}}, except
{{TestSwiftContractCreate}}.  Maybe this will be the patch where I finally get myself set
up to run Swift tests.

> Rename/split fs.contract.is-blobstore flag used by contract tests.
> ------------------------------------------------------------------
>                 Key: HADOOP-13502
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13502
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: test
>            Reporter: Chris Nauroth
>            Assignee: Chris Nauroth
>            Priority: Minor
>         Attachments: HADOOP-13502-branch-2.001.patch
> The {{fs.contract.is-blobstore}} flag guards against execution of several contract tests
to account for known limitations with blob stores.  However, the name is not entirely accurate,
because it's still possible that a file system implemented against a blob store could pass
those tests, depending on whether or not the implementation matches the semantics of HDFS.
 This issue proposes to rename the flag or split it into different flags with different definitions
for the semantics covered by the current flag.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org

View raw message