hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xiaoyu Yao (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-13502) Rename/split fs.contract.is-blobstore flag used by contract tests.
Date Mon, 03 Oct 2016 23:05:20 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-13502?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15543689#comment-15543689
] 

Xiaoyu Yao commented on HADOOP-13502:
-------------------------------------

[~cnauroth], the changes looks pretty good to me. I have one question about:
bq. Deprecated the is-blobstore flag, but retained it in case file system implementations
outside the Hadoop source tree are using it. (Side note: do we need to add audience and stability
annotations to the contract test classes?)

Can we keep is-blobstore purely as a high level flag in those *.xml files? The name itself
matches with the backstore of those file system. 
We can still use the new flags to differentiate hadoop contract test.

> Rename/split fs.contract.is-blobstore flag used by contract tests.
> ------------------------------------------------------------------
>
>                 Key: HADOOP-13502
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13502
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: test
>            Reporter: Chris Nauroth
>            Assignee: Chris Nauroth
>            Priority: Minor
>         Attachments: HADOOP-13502-branch-2.001.patch
>
>
> The {{fs.contract.is-blobstore}} flag guards against execution of several contract tests
to account for known limitations with blob stores.  However, the name is not entirely accurate,
because it's still possible that a file system implemented against a blob store could pass
those tests, depending on whether or not the implementation matches the semantics of HDFS.
 This issue proposes to rename the flag or split it into different flags with different definitions
for the semantics covered by the current flag.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message