hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Nauroth (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-13502) Rename/split fs.contract.is-blobstore flag used by contract tests.
Date Tue, 04 Oct 2016 04:25:20 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-13502?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15544304#comment-15544304
] 

Chris Nauroth commented on HADOOP-13502:
----------------------------------------

bq. Can we keep is-blobstore purely as a high level flag in those *.xml files?

It sounds like you'd like to see is-blobstore kept as a purely descriptive flag.  I can see
the appeal of that, but unfortunately, I think it would conflict with what I tried to achieve
for backward compatibility in the 001 patch.

Some of the tests were changed to check the new flags, but also continue checking the is-blobstore
flag as a fallback.  This helps for backward compatibility if there is a file system implementation
outside of the Hadoop source tree that has subclassed {{AbstractContractCreateTest}} to run
those contract tests in its own project.  If we keep is-blobstore in the XML files, then I
also need to remove the fallbacks check from the code, because I want WASB and S3A to run
the tests with the stricter checks enforced.

Overall, I'd prefer to stick with the approach in the 001 patch, but let me know your thoughts.

> Rename/split fs.contract.is-blobstore flag used by contract tests.
> ------------------------------------------------------------------
>
>                 Key: HADOOP-13502
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13502
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: test
>            Reporter: Chris Nauroth
>            Assignee: Chris Nauroth
>            Priority: Minor
>         Attachments: HADOOP-13502-branch-2.001.patch
>
>
> The {{fs.contract.is-blobstore}} flag guards against execution of several contract tests
to account for known limitations with blob stores.  However, the name is not entirely accurate,
because it's still possible that a file system implemented against a blob store could pass
those tests, depending on whether or not the implementation matches the semantics of HDFS.
 This issue proposes to rename the flag or split it into different flags with different definitions
for the semantics covered by the current flag.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message