hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-16105) WASB in secure mode does not set connectingUsingSAS
Date Mon, 18 Feb 2019 18:34:00 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-16105?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16771289#comment-16771289
] 

Steve Loughran commented on HADOOP-16105:
-----------------------------------------

David, afraid I'm going to say no to the new test because of the place it is failing, I think
there's some race conditions surfacing.

I'm happy with the patch and I think we've reached the limits of testability here.

Any other comments?

> WASB in secure mode does not set connectingUsingSAS
> ---------------------------------------------------
>
>                 Key: HADOOP-16105
>                 URL: https://issues.apache.org/jira/browse/HADOOP-16105
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: fs/azure
>    Affects Versions: 2.8.5, 3.1.2
>            Reporter: Steve Loughran
>            Assignee: Steve Loughran
>            Priority: Major
>         Attachments: HADOOP-16105-001.patch, HADOOP-16105-002.patch
>
>
> If you run WASB in secure mode, it doesn't set {{connectingUsingSAS}} to true, which
can break things



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message