hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wei-Chiu Chuang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-16152) Upgrade Eclipse Jetty version to 9.4.x
Date Fri, 01 Mar 2019 03:06:00 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-16152?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16781233#comment-16781233
] 

Wei-Chiu Chuang commented on HADOOP-16152:
------------------------------------------

Hi [~yumwang] thanks for reporting the issue.

We isolated classpath in Hadoop 3, so downstream applications shouldn't worry about Jetty
version conflicts. Or are you aware of any API compatibilities between Jetty 9.3 (which the
latest Hadoop depends on) and 9.4?

> Upgrade Eclipse Jetty version to 9.4.x
> --------------------------------------
>
>                 Key: HADOOP-16152
>                 URL: https://issues.apache.org/jira/browse/HADOOP-16152
>             Project: Hadoop Common
>          Issue Type: Improvement
>    Affects Versions: 3.2.0
>            Reporter: Yuming Wang
>            Priority: Major
>
> Some big data projects have been upgraded Jetty to 9.4.x, which causes some compatibility
issues.
> Spark: https://github.com/apache/spark/blob/5a92b5a47cdfaea96a9aeedaf80969d825a382f2/pom.xml#L141
> Calcite: https://github.com/apache/calcite/blob/avatica-1.13.0-rc0/pom.xml#L87



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message