hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-16210) Update guava to 27.0-jre in hadoop-project trunk
Date Fri, 05 Apr 2019 14:57:00 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-16210?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16810907#comment-16810907
] 

Steve Loughran commented on HADOOP-16210:
-----------------------------------------

FWIW. this broke my cloudstore builds

{code}
[INFO] Finished at: 2019-04-05T15:55:14+01:00
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.1:compile
(default-compile) on project cloudstore: Compilation failure: Compilation failure: 
[ERROR] cloudstore/src/main/java/org/apache/hadoop/fs/store/diag/StoreDiag.java:[1090,23]
cannot find symbol
[ERROR]   symbol:   method getDigest(java.io.File,java.security.MessageDigest)
[ERROR]   location: class com.google.common.io.Files
[ERROR] cloudstore/src/main/java/org/apache/hadoop/fs/store/diag/StoreDiag.java:[1095,17]
cannot find symbol
[ERROR]   symbol:   method getDigest(java.io.File,java.security.MessageDigest)
[ERROR]   location: class com.google.common.io.Files
[ERROR] -> [Help 1]
{code}

Looks like something went from google Files

> Update guava to 27.0-jre in hadoop-project trunk
> ------------------------------------------------
>
>                 Key: HADOOP-16210
>                 URL: https://issues.apache.org/jira/browse/HADOOP-16210
>             Project: Hadoop Common
>          Issue Type: Sub-task
>    Affects Versions: 3.3.0
>            Reporter: Gabor Bota
>            Assignee: Gabor Bota
>            Priority: Critical
>             Fix For: 3.3.0
>
>         Attachments: HADOOP-16210.001.patch, HADOOP-16210.002.findbugsfix.wip.patch,
HADOOP-16210.002.patch, HADOOP-16210.003.patch
>
>
> com.google.guava:guava should be upgraded to 27.0-jre due to new CVE's found CVE-2018-10237.
> This is a sub-task for trunk from HADOOP-15960 to track issues with that particular branch.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message