hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erik Krogen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-16266) Add more fine-grained processing time metrics to the RPC layer
Date Fri, 26 Apr 2019 16:28:00 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-16266?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16827104#comment-16827104
] 

Erik Krogen commented on HADOOP-16266:
--------------------------------------

In terms of more concrete comments on v005 patch:
* I agree with Steve about slf4j instead of commons-logging in {{ProcessingDetails}}, I did
not notice that before.
* We have a lot of {{long}} variable and parameters that used to store millis, but now store
nanos. Can we change the name of all of these to have a {{Nanos}} suffix? I would say millis
are sort of the de facto default, so if we are using nanos, we should make it obvious.
* I have a concern about where the {{call.isOpen()}} call is performed. Since it is called
after {{call.run()}}, the call may have been naturally closed by this point. I think we need
to store {{processed = call.isOpen()}} _before_ calling {{call.run()}}.

> Add more fine-grained processing time metrics to the RPC layer
> --------------------------------------------------------------
>
>                 Key: HADOOP-16266
>                 URL: https://issues.apache.org/jira/browse/HADOOP-16266
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: ipc
>            Reporter: Christopher Gregorian
>            Assignee: Christopher Gregorian
>            Priority: Minor
>              Labels: rpc
>         Attachments: HADOOP-16266.001.patch, HADOOP-16266.002.patch, HADOOP-16266.003.patch,
HADOOP-16266.004.patch, HADOOP-16266.005.patch
>
>
> Splitting off of HDFS-14403 to track the first part: introduces more fine-grained measuring
of how a call's processing time is split up.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message