hadoop-mapreduce-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinod Kumar Vavilapalli (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (MAPREDUCE-6355) 2.5 client cannot communicate with 2.5 job on 2.6 cluster
Date Tue, 03 Nov 2015 23:51:27 GMT

     [ https://issues.apache.org/jira/browse/MAPREDUCE-6355?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Vinod Kumar Vavilapalli resolved MAPREDUCE-6355.
------------------------------------------------
    Resolution: Won't Fix

Similar to YARN-3575, this token format-change (YARN-668) was a _"necessary evil"_ to support
rolling-upgrades starting Hadoop 2.6. I requested offline that this be filed largely for documentation
concerns.

There is only one way sites can avoid this incompatibility: all apps are to be upgraded to
2.6+ once you migrate your cluster to 2.6+ from < 2.6.

We *can* have an elaborate fix where the 2.5 clients tells YARN of its version so that RM
can generate and propagate the right token-format, but at this stage, I am not sure of its
value. Closing this for now as won't fix. Please reopen if you disagree. Thanks.


> 2.5 client cannot communicate with 2.5 job on 2.6 cluster
> ---------------------------------------------------------
>
>                 Key: MAPREDUCE-6355
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-6355
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>    Affects Versions: 2.6.0
>            Reporter: Jason Lowe
>
> Trying to run a job on a Hadoop 2.6 cluster from a Hadoop 2.5 client submitting a job
that uses Hadoop 2.5 jars results in a job that succeeds but the client cannot communicate
with the AM while the job is running.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message