hadoop-mapreduce-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Szilard Nemeth (JIRA)" <j...@apache.org>
Subject [jira] [Created] (MAPREDUCE-7161) Replace all MockRM submit method definitions with builder
Date Sat, 24 Nov 2018 14:22:00 GMT
Szilard Nemeth created MAPREDUCE-7161:

             Summary: Replace all MockRM submit method definitions with builder
                 Key: MAPREDUCE-7161
                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-7161
             Project: Hadoop Map/Reduce
          Issue Type: Improvement
            Reporter: Szilard Nemeth
            Assignee: Szilard Nemeth

MockRM has 31 definitions of submitApp, most of them having more than acceptable number of
parameters, ranging from 2 to even 22 parameters, which makes the code completely unreadable.
On top of unreadability, it's very hard to follow what RmApp will be produced for tests as
they often pass a lot of empty / null values as parameters.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: mapreduce-dev-unsubscribe@hadoop.apache.org
For additional commands, e-mail: mapreduce-dev-help@hadoop.apache.org

View raw message