hadoop-mapreduce-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Loughran <ste...@cloudera.com.INVALID>
Subject builds failing on trunk, "convergence failure"?
Date Tue, 26 Feb 2019 14:47:51 GMT
Is anyone else seeing mr-client-app failing to build with a convergence
error? It's started for me today on trunk


[INFO] --- maven-enforcer-plugin:3.0.0-M1:enforce (depcheck) @
hadoop-mapreduce-client-app ---
[WARNING]
Dependency convergence error for org.hamcrest:hamcrest-core:1.1 paths to
dependency are:
+-org.apache.hadoop:hadoop-mapreduce-client-app:3.3.0-SNAPSHOT
  +-com.github.stefanbirkner:system-rules:1.18.0
    +-junit:junit-dep:4.11.20120805.1225
      +-org.hamcrest:hamcrest-core:1.1
and
+-org.apache.hadoop:hadoop-mapreduce-client-app:3.3.0-SNAPSHOT
  +-junit:junit:4.12
    +-org.hamcrest:hamcrest-core:1.3

[WARNING] Rule 0: org.apache.maven.plugins.enforcer.DependencyConvergence
failed with message:
Failed while enforcing releasability. See above detailed error message.


It's only a trivial pom fixup, but I'm surprised its suddenly surfaced. Am
I the only person seeing it?

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message