hadoop-yarn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ajesh Kumar (JIRA)" <j...@apache.org>
Subject [jira] [Created] (YARN-1562) Getting ClassNotFoundException even though jar is included in lib folder
Date Mon, 06 Jan 2014 05:03:50 GMT
Ajesh Kumar created YARN-1562:

             Summary: Getting ClassNotFoundException even though jar is included in lib folder
                 Key: YARN-1562
                 URL: https://issues.apache.org/jira/browse/YARN-1562
             Project: Hadoop YARN
          Issue Type: Bug
          Components: applications
         Environment: GNU/Linux 3.2.0-29-generic x86_64
            Reporter: Ajesh Kumar

In YARN, we are getting the below exception. The same is running fine in MRv1.The jar containing
CSVReader.class in included in the lib folder.
Tried also setting the jar in HADOOP_CLASSPATH as well,but still the same exception.
13/12/31 09:26:37 INFO mapreduce.Job: map 0% reduce 0%
13/12/31 09:26:42 INFO mapreduce.Job: Task Id : attempt_1388462142258_0001_m_000003_0, Status
Error: java.lang.RuntimeException: Error in configuring object
at org.apache.hadoop.util.ReflectionUtils.setJobConf(ReflectionUtils.java:106)
at org.apache.hadoop.util.ReflectionUtils.setConf(ReflectionUtils.java:72)
at org.apache.hadoop.util.ReflectionUtils.newInstance(ReflectionUtils.java:130)
Caused by: java.lang.NoClassDefFoundError: au/com/bytecode/opencsv/CSVReader
at com.tcs.nextgen.pe.wm.datagen.maptask.MPOCDataMapperNewest.configure(MPOCDataMapperNewest.java:56)
... 22 more
Caused by: java.lang.ClassNotFoundException: au.com.bytecode.opencsv.CSVReader
at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)

This message was sent by Atlassian JIRA

View raw message