hadoop-yarn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinod Kumar Vavilapalli (JIRA)" <j...@apache.org>
Subject [jira] [Created] (YARN-1693) Cleanup YARN HAUtil class
Date Fri, 07 Feb 2014 03:22:20 GMT
Vinod Kumar Vavilapalli created YARN-1693:

             Summary: Cleanup YARN HAUtil class
                 Key: YARN-1693
                 URL: https://issues.apache.org/jira/browse/YARN-1693
             Project: Hadoop YARN
          Issue Type: Sub-task
            Reporter: Vinod Kumar Vavilapalli
            Assignee: Vinod Kumar Vavilapalli

The HAUtil class has become a bit of a mess. It is 
 - unreadable/unmaintainable
 - has non-standard formatting in some places
 - has no javadoc for the myriad of methods
 - with bad/not-so-clear field naming
 - and simply just complicated.

I'll try to put some structure, adding comments and renaming things. Hopefully for better.

This message was sent by Atlassian JIRA

View raw message