hadoop-yarn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Wang <gw...@gopivotal.com>
Subject Re: Compatibility Yarn 2.4 with HDFS 2.0
Date Sun, 08 Jun 2014 03:32:32 GMT
Not sure which version of HDFS you are using. You mean 2.0.5 or any other?

In hadoop 2.4.0, the protobuf version is bumped up to 2.5.0. But in 2.0.5,
the protobuf is 2.4.1.
So, I think they may not be compatible even if you change the dependency in
pom.

And I never try to put different HDFS and YARN together. There may be some
other issues.


On Fri, Jun 6, 2014 at 4:22 PM, 张鹏 <peng.zhang@xiaomi.com> wrote:

> Hi all,
>
> I want to upgrade to Yarn 2.4 only. But when it access Hdfs, IPC Server
> version is mismached.
>
> HDFS (IPC v7) cant respond to YARN (IPC v9) with below error log:
> WARN org.apache.hadoop.ipc.Server: Incorrect header or version mismatch
> from 127.0.0.1:47957 got version 9 expected version 7
>
> I want to know whether it is possible to do this?
>
> Maybe I can change pom to depend on hdfs 2.0, and use maven shade to make
> hadoop common(2.4 and 2.0) work together
>
> Any suggestions?
>
> --
> Thanks,
> Peng
>
>


-- 
Regards
Gordon Wang

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message