hadoop-yarn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wangda Tan <wheele...@gmail.com>
Subject Cannot create release artifacts for branch-2.8
Date Tue, 07 Jun 2016 05:50:22 GMT
Hi Hadoop Devs,

As you know, we're pushing 2.8.0 releases recently, there're couple of
issues that block creating release artifacts from source code.

I tried following approaches:
1) Run build through Hadoop Jenkins Job:
2) Run dev-support/create-release.sh

There're at most two issues cause the problem from what I can see:
1) https://issues.apache.org/jira/browse/HADOOP-12022 removed
2) https://issues.apache.org/jira/browse/HADOOP-11792 removed all

I have tried to revert HADOOP-12022/HADOOP-11792 locally in branch-2.8,
create-releases.sh can run through and generate docs/artifacts correctly
(at least layout looks correctly, I haven't verified generated bits).

To make sure releases are not blocked, we have a couple of options:
a. Fix HADOOP-12892 and related issues, which requires to backport a couple
of commits which marked to be incompatible.
b. Revert both of the commits, and manual fix CHANGES.txt.

Any helps/suggestions are welcome.


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message