hadoop-yarn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jinjiang Ling (JIRA)" <j...@apache.org>
Subject [jira] [Created] (YARN-7698) A misleading variable's name in ApplicationAttemptEventDispatcher
Date Thu, 04 Jan 2018 12:03:00 GMT
Jinjiang Ling created YARN-7698:

             Summary: A misleading variable's name in ApplicationAttemptEventDispatcher
                 Key: YARN-7698
                 URL: https://issues.apache.org/jira/browse/YARN-7698
             Project: Hadoop YARN
          Issue Type: Improvement
          Components: resourcemanager
            Reporter: Jinjiang Ling
            Assignee: Jinjiang Ling
            Priority: Minor

I find there are two variables named "appAttemptId" in ApplicationAttemptEventDispatcher.
public static final class ApplicationAttemptEventDispatcher implements
      EventHandler<RMAppAttemptEvent> {
    public void handle(RMAppAttemptEvent event) {
      ApplicationAttemptId appAttemptID = event.getApplicationAttemptId();
      ApplicationId appAttemptId = appAttemptID.getApplicationId();
The first one is named as "{color:red}appAttemptID{color}" which is the true attempt id. 
The other one is named as  "{color:red}appAttemptId{color}", but I think it's currect name
should be "appId".

I'm not sure there are any reason to name the application id as "appAttemptId". But I think
two "appAttemptId" in one function may cause some misleading, so it's better to fix the second
one to "appId"

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: yarn-dev-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-dev-help@hadoop.apache.org

View raw message