hadoop-yarn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Akira Ajisaka <aajis...@apache.org>
Subject [DISCUSS] Removal of old hamlet package in 3.3+ or 3.4+
Date Mon, 21 Jan 2019 04:08:06 GMT
Hi folks,

I'd like to remove the deprecated hamlet package to reduce the maintenance cost.

The old hamlet package has one character '_' and it is banned in Java
9+, so HADOOP-11875 deprecated this package and created a profile in
pom.xml not to compile the package when the Java version is 9+. After
the deprecation, we still have to maintenance the profile (see
YARN-8123 and HADOOP-16046).

The only usage I can see is Apache Slider, however, the
functionalities of Apache Slider have been merged into YARN. Therefore
I think there are no people using Slider with Hadoop 3.1+ and we can
remove the package in 3.3+.

Any thoughts?

Regards,
Akira

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-dev-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-dev-help@hadoop.apache.org


Mime
View raw message