hama-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edward J. Yoon" <edwardy...@apache.org>
Subject Re: Problem running examples in hama
Date Thu, 24 Jun 2010 22:54:16 GMT
Hello,

Please try to run the following command: # bin/hama
org.apache.hama.examples.ExampleDriver

I'll add example launcher command to run script soon.

Thanks!

On Thu, Jun 24, 2010 at 9:48 PM, Peeyush Kumar <agoovi@gmail.com> wrote:
> Hi,
>
>      I compiled the latest hama-trunk version with the newest version of
> hbase(0.20.4) and zookeeper lib files and when I run the examples
> $hama-home/bin/hama examples rand 20 20 20% tmp I got class not found
> exception
> Exception in thread "main" java.lang.
> NoClassDefFoundError: examples
> Caused by: java.lang.ClassNotFoundException: examples
>       at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
>       at java.security.AccessController.doPrivileged(Native Method)
>       at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
>       at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
>       at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
>       at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
> Could not find the main class: examples.  Program will exit.
>
> Could you please help me on this. I am using hbase and hama for the first
> time.
>
> Thanks
> Peeyush
>



-- 
Best Regards, Edward J. Yoon
edwardyoon@apache.org
http://blog.udanax.org

Mime
View raw message