hama-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fancy Yin <yfxh...@gmail.com>
Subject Re: One hama zookeeper clientPort problem
Date Wed, 01 Jun 2011 02:40:51 GMT
Hi, Edward:

It works!
Thanks.

Hama is a cool project!

B.R.
Fancy

2011/5/30, Edward J. Yoon <edwardyoon@apache.org>:
> Hi,
>
>>  40     <property>
>>  41         <name>hama.zookeeper.property.clientPort</name>
>>  42         <value>2181</value>
>>  43     </property>
>
> Please try like this:
>
> <name>zookeeper.client.port</name>
> <value>2181</value>
>
> On Mon, May 30, 2011 at 12:38 PM, Fancy Yin <yfxhust@gmail.com> wrote:
>> Hello:
>>
>> I am interesting in Hama project. I want to do some experimental work
>> with it. But I met a problem when I set up the Hama enviroment.
>>
>> I have set up one Hadoop and a zooKeeper.
>> I have already one zooKeeper instance, so I disable zookeeper manager
>> in hama as followers in hama-env.sh:
>> export HAMA_MANAGES_ZK=false
>>
>> And configure the settings in hama-site.xml
>>  35     <property>
>>  36         <name>hama.zookeeper.quorum</name>
>>  37         <value>127.0.1.1</value>
>>  38     </property>
>>  39
>>  40     <property>
>>  41         <name>hama.zookeeper.property.clientPort</name>
>>  42         <value>2181</value>
>>  43     </property>
>>
>> In my zoo.cfg in zookeeper-3.3.3, I also configure it as follows:
>> clientPort=2181
>>
>> Then I start hama and run hama-0.20.0-examples.jar for PI test. It
>> generates errors:
>>
>> 2011-05-30 10:47:28,639 INFO org.apache.zookeeper.ClientCnxn: Opening
>> socket connection to server 127.0.1.1/127.0.1.1:21810
>> 2011-05-30 10:47:28,640 WARN org.apache.zookeeper.ClientCnxn: Session
>> 0x0 for server null, unexpected error, closing socket connection and
>> attempting reconnect
>> java.net.ConnectException: Connection refused
>>        at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
>>        at
>> sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:574)
>>        at
>> org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1078)
>>
>> But if I change clientPort from 2181 to 21810  in my zoo.cfg in my
>> zookeeper-3.3.3, it works.
>>
>> It seems that I couldn't change zookeeper clientPort. It  is allowed
>> to be 21810. I can't change it to other value.
>>
>> I don't know whether it is a bug for Hama.
>> Is there any people know it ?
>>
>> Thank you!
>>
>> B.R.
>> Fancy
>>
>
>
>
> --
> Best Regards, Edward J. Yoon
> @eddieyoon
>

Mime
View raw message