hama-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edward J. Yoon" <edwardy...@apache.org>
Subject Re: SAXParseException &# chain jobs
Date Sat, 04 May 2013 01:50:05 GMT
Congratz :-)

> I now have another question. Is there a way to sort the messages that come
> to a vertex before the vertex reads them?

I'm not sure what you mean exactly?

On Fri, May 3, 2013 at 10:16 PM, Ilias Kapouranis <ikapoura@csd.auth.gr> wrote:
> Hello again,
>
>   i finally solved it! I was reading the parameters from a file, so the
> problem had to do something with the encoding of the file. So I just added a
> .trim() at my parameter variable when I was assigning it to the job and it
> worked!
>
>   I now have another question. Is there a way to sort the messages that come
> to a vertex before the vertex reads them?
>
>   Thanks again!
>
>
> Quoting Ηλίας Καπουράνης <ikapoura@csd.auth.gr>:
>
>> Hey Edward!
>>
>> Ok i will check your suggestion! I havent tested it thoroughly because it
>> was a bit late and
>> wanted to see if you have any thoughts. Will be back soon with the
>> solution or any other
>> persistent problems..!
>>
>> Thanks!
>>
>> Στις 26/4/2013 4:34 πμ, ο/η Edward J. Yoon έγραψε:
>>>
>>> Hello Ilias Kapouranis,
>>>
>>> Can you provide more details? I think you need to investigate whether
>>> it came from command-line options or your application.
>>>
>>> On Fri, Apr 26, 2013 at 8:01 AM, Ilias Kapouranis <ikapoura@csd.auth.gr>
>>> wrote:
>>>>
>>>> Hello all!
>>>>
>>>>   I am working with Hama Graph module and i try to chain some jobs in a
>>>> for
>>>> loop.The first loop runs normally, but when it enters the second I get
>>>> the
>>>> following exceptions:
>>>>
>>>> INFO bsp.FileInputFormat: Total input paths to process : 1
>>>> [Fatal Error] :60:42: Character reference "&#
>>>> 13/04/26 01:48:45 FATAL conf.Configuration: error parsing conf file:
>>>> org.xml.sax.SAXParseException; lineNumber: 60; columnNumber: 42;
>>>> Character
>>>> reference "&#
>>>> Exception in thread "Thread-33" java.lang.RuntimeException:
>>>> org.xml.sax.SAXParseException; lineNumber: 60; columnNumber: 42;
>>>> Character
>>>> reference "&#
>>>>         at
>>>>
>>>> org.apache.hadoop.conf.Configuration.loadResource(Configuration.java:1263)
>>>>         at
>>>>
>>>> org.apache.hadoop.conf.Configuration.loadResources(Configuration.java:1129)
>>>>         at
>>>> org.apache.hadoop.conf.Configuration.getProps(Configuration.java:1063)
>>>>         at
>>>> org.apache.hadoop.conf.Configuration.set(Configuration.java:439)
>>>>         at
>>>> org.apache.hadoop.conf.Configuration.setClass(Configuration.java:942)
>>>>         at
>>>> org.apache.hama.bsp.LocalBSPRunner.submitJob(LocalBSPRunner.java:120)
>>>>         at
>>>> org.apache.hama.bsp.BSPJobClient.launchJob(BSPJobClient.java:396)
>>>>         at
>>>>
>>>> org.apache.hama.bsp.BSPJobClient.submitJobInternal(BSPJobClient.java:372)
>>>>         at
>>>> org.apache.hama.bsp.BSPJobClient.submitJob(BSPJobClient.java:295)
>>>>         at org.apache.hama.bsp.BSPJob.submit(BSPJob.java:218)
>>>>         at org.apache.hama.graph.GraphJob.submit(GraphJob.java:171)
>>>>         at org.apache.hama.bsp.BSPJob.waitForCompletion(BSPJob.java:225)
>>>>         at testhama.threadRun.run(threadRun.java:136)
>>>>         at java.lang.Thread.run(Thread.java:722)
>>>> Caused by: org.xml.sax.SAXParseException; lineNumber: 60; columnNumber:
>>>> 42;
>>>> Character reference "&#
>>>>         at
>>>>
>>>> com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(DOMParser.java:251)
>>>>         at
>>>>
>>>> com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(DocumentBuilderImpl.java:300)
>>>>         at
>>>> javax.xml.parsers.DocumentBuilder.parse(DocumentBuilder.java:121)
>>>>         at
>>>>
>>>> org.apache.hadoop.conf.Configuration.loadResource(Configuration.java:1188)
>>>>
>>>>
>>>>    This shows up ONLY if I start jobs with different configurations. If
>>>> I
>>>> start a new job with the same conf settings as the previous one,
>>>> everything
>>>> is fine.
>>>>    I searched with google but the only thing that I found is that
>>>> someone
>>>> had the same problem and it has to do something with temporary xml
>>>> files.
>>>> Unfortunately, he didn't have any solution to my problem.
>>>>
>>>>    Any thoughts from you? Thanks in advance!
>>>>
>>>>
>>>
>>>
>>
>>
>
>
>



--
Best Regards, Edward J. Yoon
@eddieyoon

Mime
View raw message