hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryan Duxbury <br...@rapleaf.com>
Subject Re: Regions Offline
Date Fri, 18 Apr 2008 00:41:24 GMT
For starters, what version of HBase/Hadoop are you using? There was a  
pretty bad bug in 0.16 that would cause regions to go offline and all  
sorts of other unexpected behavior.
-Bryan

On Apr 28, 2008, at 5:00 PM, David Alves wrote:

> Hi
>
> 	My system is quite simple:
> 	- two (one quad core, one dual core) servers with 2GB mem and 150 GB
> allocated to dfs.
> 	- I use it to crawl multiple supports but mainly filesystems and
> save the results onto hbase (not too many files < 100.000 but rows  
> can get
> easily to 30 MB each)
>
> 	I constantly getting NullPointerExceptions (on the client caused by
> NotServingRegionExceptions on regionserver) when creating tables or
> RegionOfflineExceptions when doing puts or sometimes just time outs.
> 	When started with hbase I developed in 'local' mode, I then migrated
> to a small dev 2 servers cluster (weaker than production is now)  
> where I
> tested the functionality, and it worked fine but, my bad, due to  
> pressing
> scheduling I didn't do any real load tests, so the system is now
> continuously going under in production. I've only been able to do a  
> full
> crawl by resetting the cluster to one node and putting it in  
> 'local' mode.
>
> 	My question is what can cause regions to be offline in
> regionservers?
>
> 	I ask so that I can investigate the matter further but having a
> starting point.
>
> 	I'm willing to help anyway I can but I would really appreciate any
> help and/or starting point and tools for my investigation.
>
>
> Best Regards
> David Alves
>


Mime
View raw message