hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Kellerman <...@powerset.com>
Subject RE: HBase with HDFS - Setup problem
Date Wed, 06 Aug 2008 16:35:56 GMT
hbase-0.1.3 is not compatible with hadoop-0.17.x it only runs on hadoop-0.16.x

---
Jim Kellerman, Senior Engineer; Powerset


> -----Original Message-----
> From: chris.paterson@bt.com [mailto:chris.paterson@bt.com]
> Sent: Wednesday, August 06, 2008 6:20 AM
> To: hbase-user@hadoop.apache.org
> Subject: HBase with HDFS - Setup problem
>
> Afternoon all,
>
> I'm attempting to setup HBase 0.1.3 to run on top of the
> Hadoop 0.17.1 DFS, however I'm having trouble. HBase is
> running at the moment (I can enter the shell, and create/show
> tables), however stopping the HDFS has no effect, therefore
> suggesting that HBase is running using the local filesystem
> rather than the HDFS. I'd really appreciate any suggestions!
>
> Below is my hbase-site.xml file:
>
>         <configuration>
>           <property>
>             <name>hbase.rootdir</name>
>             <value>hdfs://127.0.0.1:9000/hbase</value>
>             <description>The directory shared by region servers.
>             Should be fully-qualified to include the
> filesystem to use.
>             E.g: hdfs://NAMENODE_SERVER:PORT/HBASE_ROOTDIR
>             </description>
>           </property>
>             <property>
>             <name>hbase.master</name>
>             <value>local</value>
>             <description>The host and port that the HBase
> master runs at.
>             A value of 'local' runs the master and a regionserver in
>             a single process.
>             </description>
>           </property>
>         </configuration>
>
>
>
> And my hadoop-site.xml:
>
>          <property>
>           <name>fs.default.name</name>
>           <value>hdfs://127.0.0.1:9000</value>
>          </property>
>
>             <property>
>                 <name>mapred.job.tracker</name>
>                 <value>hdfs://127.0.0.1:9001</value>
>             </property>
>
>          <property>
>           <name>dfs.name.dir</name>
>           <value>/usr/hadoop/hdfs/name</value>
>          </property>
>
>          <property>
>           <name>dfs.data.dir</name>
>           <value>/usr/hadoop/hdfs/data</value>
>          </property>
>
>             <property>
>                 <name>dfs.replication</name>
>           <value>3</value>
>             </property>
>
>          <property>
>           <name>mapred.child.java.opts</name>
>           <value>-Xmx2000m</value>
>          </property>
>
>          <property>
>           <name>mapred.map.tasks</name>
>           <description>10x number of slaves</description>
>                 <value>120</value>
>             </property>
>
>
> Regards,
> Chris Paterson
>
>
>
> No virus found in this incoming message.
> Checked by AVG - http://www.avg.com
> Version: 8.0.138 / Virus Database: 270.5.12/1595 - Release
> Date: 8/6/2008 8:23 AM
>

Mime
View raw message