hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Toby White <toby.o.h.wh...@googlemail.com>
Subject duplicated hbase timestamps
Date Mon, 20 Oct 2008 15:11:20 GMT
I'm seeing a strange effect on my hbase instance. Sometimes, on  
requesting the full history of a column, I get back individual cells  
several times over.

That is, I'm getting results like this:

base(main):006:0* get 'my_table', 'scw9npU7Q4ma_khXqlDGXg', {COLUMN =>  
'value:', VERSIONS=>4000}
timestamp=1224504133000, value=1013.0
timestamp=1224502749000, value=1012.0
timestamp=1224502749000, value=1012.0
timestamp=1224499880000, value=1011.0
timestamp=1224499880000, value=1011.0
timestamp=1224499880000, value=1011.0
timestamp=1224415961000, value=1010.0
timestamp=1224415961000, value=1010.0
timestamp=1224415961000, value=1010.0
timestamp=1224415701000, value=1009.0
timestamp=1224415701000, value=1009.0
timestamp=1224415701000, value=1009.0
timestamp=1224414200000, value=1008.0
timestamp=1224414200000, value=1008.0
timestamp=1224414200000, value=1008.0

This happens both through the hbase shell as shown here, and when  
communicating with the server via thrift.

In either case, the cells are reported either as shown above; that is,  
with each cell simply repeated several times (in this case, 3) or  
sometimes with the series repeated; something like this:

base(main):006:0* get 'golddigger', 'scw9npU7Q4ma_khXqlDGXg', {COLUMN  
=> 'value:', VERSIONS=>4000}
timestamp=1224504133000, value=1013.0
timestamp=1224502749000, value=1012.0
timestamp=1224499880000, value=1011.0
timestamp=1224415961000, value=1010.0
timestamp=1224415701000, value=1009.0
timestamp=1224414200000, value=1008.0
timestamp=1224504133000, value=1013.0
timestamp=1224502749000, value=1012.0
timestamp=1224499880000, value=1011.0
timestamp=1224415961000, value=1010.0
timestamp=1224415701000, value=1009.0
timestamp=1224414200000, value=1008.0

or sometimes a combination of both ie an entire series, each cell  
repeated a couple of times, and then the whole lot repeated again.

This doesn't happen with all rows, only some of them, apparently at  
random. Sometimes, restarting hbase & the underlying hdf makes the  
problem go away; sometimes, it doesn't, and the issue persists.

This is with hbase 0.18.0 on hadoop 0.18.1

Is this a known issue?

Mime
View raw message