hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Stack <st...@duboce.net>
Subject Re: Again UnknowScannerException
Date Wed, 10 Dec 2008 05:57:49 GMT
Edward J. Yoon wrote:
> To change hbase.regionserver.lease.period, Should I restart hbase cluster?
>   
Edward: Yes, unfortunately (should make it so you don't have to).

David: Please upgrade to hbase 0.18.1 for other reasons than 

hbase.regionserver.lease.period

(and hadoop 0.18.2).  You do not need to upgrade hadoop to run hbase 
0.18.1 (or viceversa).  If lease period is all you want to change 
(HBASE-821), you don't need to upgrade; just make the change in your 
configuration (as J-D says) and copy it around your cluster.

St.Ack




> On Sat, Nov 22, 2008 at 1:33 AM, Jean-Daniel Cryans <jdcryans@apache.org> wrote:
>   
>> David,
>>
>> You should indeed increase your hbase.regionserver.lease.period to at least
>> 2 minutes.
>>
>> J-D
>>
>> On Fri, Nov 21, 2008 at 4:55 AM, David Alves <dalves@student.dei.uc.pt>wrote:
>>
>>     
>>> Hi
>>>
>>>        I've seen this issue a lot in the mailing list, but I still have a
>>> doubt.
>>>        My map tasks keep failing with unknownscannerexception (2 map tasks
>>> on same node over a 3 node cluster with 4Gb mem, scanning almost 40 GBs of
>>> data, running hadoop 0.18.0, and hbase 0.18.0), this happened in the past,
>>> but as it passed 50% of the times rarely a M/R task completely failed, as
>>> the data increased the USE now completely prevents the maps from running to
>>> completion. I'm only scanning the table, there are no inserts at the same
>>> time.
>>>        I've previouly seen mentioned a lease period I could increase. Is
>>> this the "hbase.regionserver.lease.period" property? Should I upgrade to
>>> hbase 0.18.1, and if so must I also update hadoop?
>>>
>>> Regards
>>> David Alves
>>>
>>>
>>>
>>>       
>
>
>
>   


Mime
View raw message