hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cambridgemike <saidthero...@gmail.com>
Subject Re: PerformanceEvaluation test
Date Wed, 10 Jun 2009 23:54:56 GMT

Hi, I'm having almost the exact same problem (this rowcounter jar is one I
compiled myself) 

./bin/hadoop jar rowcounter.jar org.myorg.RowCounter /user/myUser/output/
09/06/10 19:44:19 INFO mapred.TableInputFormatBase: split:
09/06/10 19:44:19 INFO mapred.TableInputFormatBase: split:
09/06/10 19:44:19 INFO mapred.JobClient: Running job: job_200906101852_0004
09/06/10 19:44:20 INFO mapred.JobClient:  map 0% reduce 0%
09/06/10 19:44:24 INFO mapred.JobClient: Task Id :
attempt_200906101852_0004_m_000000_0, Status : FAILED
java.io.IOException: Split class org.apache.hadoop.hbase.mapred.TableSplit
not found
	at org.apache.hadoop.mapred.MapTask.run(MapTask.java:314)

After reading through this forum I: 
 -fiddled with my HADOOP_CLASSPATH in hadoop/conf/hadoop-env.sh 
 -tried restarting hbase and hadoop, and finally, 
 -tried moving hbase-0.19.2.jar to the hadoop/lib folder of all the slave

Still not working though, what exactly was required to get this to work?


llpind wrote:
> Hey Andy,
> Yeah I eventually did that instead.  It just bothers me why it doesn't
> work otherwise.  Anyway, thanks to all 
> Andrew Purtell-2 wrote:
>> For what it's worth, I deploy HBase jars into the Hadoop library
>> directory so I don't have to deal with this. Way back I had classpath
>> problems with 'hadoop jar', and not just with HBase. That may not be a
>> satisfactory answer, but it works for me. 
>>    - Andy

View this message in context: http://www.nabble.com/PerformanceEvaluation-test-tp23946437p23973184.html
Sent from the HBase User mailing list archive at Nabble.com.

View raw message