hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nitay <nit...@gmail.com>
Subject Re: post-1606 world
Date Mon, 06 Jul 2009 15:50:47 GMT
Hi Rong-En,

What do you mean HBASE_MANAGES_ZK is broken? HBase currently doesn't manage
a full ZK Quorum, but will soon. This is HBASE-1551, which I am close to
having working.

We moved the zoo.cfg to the XML files to make things easier on users. If you
have a ZooKeeper cluster setup, all you need to do is add the property
"hbase.zookeeper.quorum". If you overwrote some of the defaults, say
tickTime, then you need to add those properties as well, named e.g.
hbase.zookeeper.property.timeTime. If you look at the bottom of
hbase-default.xml, it will describe things in more detail.

So, right now you still need to setup your own quorum ZK, and point HBase to
it using "hbase.zookeeper.quorum". Soon you won't have to do your own setup
of the ZK, but you'll always have to still have to fill out the
"hbase.zookeeper.quorum" property.

Hope that helps.

-n

On Sun, Jul 5, 2009 at 9:13 PM, Rong-en Fan <grafan@gmail.com> wrote:

> After 1606 went in, how can I proper configure zookeeper and start it?
> Tried it during the weekend, looks like current HBASE_MANAGES_ZK
> is broken. In 1606, Nitay, mentioned there is a ZKServerTool?
>
> BTW, it seems to me that for hbase user, they don't need to worry about
> what zookeeper really is? As 1606 wrappers zk servers in hbase-site.xml...
>
> Any ideas?
>
> Thanks,
> Rong-En Fan
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message