hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yabo-Arber Xu <arber.resea...@gmail.com>
Subject Re: Fail to delete columns
Date Mon, 12 Oct 2009 07:42:48 GMT
Thanks, Stack. After another couple of rounds of trial and fail, finally
found that completely deleting a row works for me, but delete partially some
cells are broken. I will make an issue once I confirmed the bug.

On Mon, Oct 12, 2009 at 7:13 AM, stack <stack@duboce.net> wrote:

> It surprising that none of the deletes work in 0.19.  Deletes have unit
> tests and if deletes didn't work at all, the catalog tables would work
> properly.   Does a simple delete of a cell work?   I took a look at hbase
> 0.19.2 and 0.19.3 and at fixes committed since 0.19.3.  They do not seem to
> have any fixes related to deletes.
>
> If you can make a test that proves deletes broken, I can take a look at it.
> Make an issue.
>
> Yours,
> St.Ack
>
>
>
> On Sun, Oct 11, 2009 at 7:24 AM, Yabo-Arber Xu <arber.research@gmail.com
> >wrote:
>
> > Thanks for your reply, Stack. Our project has been in production mode.
> > Migration is definitely a future work, but may not be a good time now.
> >
> > Is there any delete method proved to be working in 0.19.1?
> >
> > Best,
> > Arber
> >
> >
> > On Sun, Oct 11, 2009 at 2:56 PM, stack <stack@duboce.net> wrote:
> >
> > > Can you move to 0.20.0 Arber? (See the migration up on the hbase wiki).
> > > Deletes are "better" in the new hbase -- expanded vocabulary and better
> > > testing.
> > > Yours,
> > > St.Ack
> > >
> > > On Sat, Oct 10, 2009 at 9:15 PM, Yabo-Arber Xu <
> arber.research@gmail.com
> > > >wrote:
> > >
> > > > Hi there,
> > > >
> > > > I am using HBase 0.19.1 API, and try to call deleteFamily method to
> > > delete
> > > > one of the column. The way to call is straightforward as follows:
> > > >
> > > >        HBaseConfiguration config = new HBaseConfiguration();
> > > >        m_table = new HTable( config, tblName );
> > > >        m_table.deleteFamily(rowkey, "review");  //review is a column
> > > family
> > > > name
> > > >
> > > > It does not seem to work. After runing the above code, all the cells
> > > under
> > > > this column family are still there. Is it a bug or I use it in a
> wrong
> > > way?
> > > > I tried other delete method like deleteAll, and they failed as well.
> > > >
> > > > Thanks for your time!
> > > >
> > > > Arber
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message