hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yannis Pavlidis" <ypavli...@oneriot.com>
Subject ROOT table does not get re-assigned
Date Wed, 14 Oct 2009 22:32:29 GMT
Hi all,

We are in the process of evaluating hadoop/hbase (using hadoop-0.20.1 and hbase-0.20.0) for
some of our needs and I wanted to ask a question related with behavior I am seeing during
our evaluation.

I have a small cluster setup containing for your simplicity: server1, server2, server3. Currently
server1 runs the namenode for hadoop and server1, server2 and server3 run the datanodes. 

In addition, server1 is the master and server1, server2 and server3 run regionservers.

During my testing I see in the master logs that ROOT table has been assigned to server2 and
META table has been assigned to server3 (I also have hbase managing zookeeper)

I run some of my tests and everything is working correctly (I am able to put/get/delete in

Then I kill (simply kill <pid>) the regionserver on server1 (which holds neither ROOT
or META regions) and everything is working properly (run the same suite).

Then I kill (simply kill <pid>) the regionserver that has ROOT assigned to it and it
appears that the master never re-assigns the ROOT to another regionserver (there is still
one running which also has the META region).

I can see the clients attempting to connect to server2 which is the regionserver that had
the ROOT region (which is not running any more) and also I can see from web ui when I run
the zkdump that the Region server holding ROOT: is still server2. 

This seems to be very easily reproducible by following the above steps (I have seen it getting
reproduced with different server assignments of the META and ROOT tables).

I also tried using hbase-0.20-1 but I still seem to be getting the same results.

Any help would be highly appreciated.   

Thanks in advance,

Yannis Pavlidis.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message