hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yannis Pavlidis" <ypavli...@oneriot.com>
Subject RE: ROOT table does not get re-assigned
Date Wed, 14 Oct 2009 23:12:32 GMT
Hi Ryan,

Thanks for the quick response. Here are master logs you have requested. For your convenience:

10.129.1.182 (cache02) has the ROOT assigned to it
10.129.1.181 (cache01) has the META assigned to it
10.129.1.186 (search01) is simply a region server.

First I kill search01 and then I kill cache02 (ROOT).

Thanks,

Yannis.

--
Search for the Pulse

Yannis Pavlidis | OneRiot
Softwarist
talk: 720.771.7025
write: ypavlidis@oneriot.com
web: www.oneriot.com




-----Original Message-----
From: Ryan Rawson [mailto:ryanobjc@gmail.com]
Sent: Wed 10/14/2009 4:37 PM
To: hbase-user@hadoop.apache.org
Subject: Re: ROOT table does not get re-assigned
 
Can you run this with DEBUG logs and paste in the master logs?
Without a detailed description of what the master is doing, hard to
diagnose.

Thanks!
-ryan

On Wed, Oct 14, 2009 at 3:32 PM, Yannis Pavlidis <ypavlidis@oneriot.com> wrote:
> Hi all,
>
> We are in the process of evaluating hadoop/hbase (using hadoop-0.20.1 and hbase-0.20.0)
for some of our needs and I wanted to ask a question related with behavior I am seeing during
our evaluation.
>
> I have a small cluster setup containing for your simplicity: server1, server2, server3.
Currently server1 runs the namenode for hadoop and server1, server2 and server3 run the datanodes.
>
> In addition, server1 is the master and server1, server2 and server3 run regionservers.
>
> During my testing I see in the master logs that ROOT table has been assigned to server2
and META table has been assigned to server3 (I also have hbase managing zookeeper)
>
> I run some of my tests and everything is working correctly (I am able to put/get/delete
in tables).
>
> Then I kill (simply kill <pid>) the regionserver on server1 (which holds neither
ROOT or META regions) and everything is working properly (run the same suite).
>
> Then I kill (simply kill <pid>) the regionserver that has ROOT assigned to it and
it appears that the master never re-assigns the ROOT to another regionserver (there is still
one running which also has the META region).
>
> I can see the clients attempting to connect to server2 which is the regionserver that
had the ROOT region (which is not running any more) and also I can see from web ui when I
run the zkdump that the Region server holding ROOT: is still server2.
>
> This seems to be very easily reproducible by following the above steps (I have seen it
getting reproduced with different server assignments of the META and ROOT tables).
>
> I also tried using hbase-0.20-1 but I still seem to be getting the same results.
>
> Any help would be highly appreciated.
>
> Thanks in advance,
>
> Yannis Pavlidis.
>



Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message