hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Daniel Cryans <jdcry...@apache.org>
Subject Re: IO Exception on startup
Date Mon, 04 Jan 2010 18:29:20 GMT
Per http://hadoop.apache.org/hbase/docs/r0.20.2/api/overview-summary.html#fully-distrib

hbase.master isn't specified there anymore. You must set
hbase.zookeeper.quorum which by default is "localhost".

J-D

On Mon, Jan 4, 2010 at 12:42 AM, alaa nobani <alaa_nobani@yahoo.com> wrote:
> Hi, yes we have hbase-site.xml with the following entries:
>
> <configuration>
> <property>
> <name>hbase.rootdir</name>
> <value>hdfs://localhost:10011/hbase</value>
> <description>The directory shared by region servers.
> </description>
> </property>
> <property>
> <name>hbase.master</name>
> <value>localhost:10015</value>
> <description>The host and port that the HBase master runs at.</description>
> </property>
> <property>
> <name>hbase.master.info.port</name>
> <value>15040</value>
> </property>
> <property>
> <name>hbase.regionserver</name>
> <value>0.0.0.0:10016</value>
> </property>
> <property>
> <name>hbase.regionserver.info.port</name>
> <value>15050</value>
> </property>
> <property>
>        <name>hbase.regionserver.class</name>
>        <value>org.apache.hadoop.hbase.ipc.IndexedRegionInterface</value>
>        <description>Admo uses indexed regions</description>
>    </property>
>    <property>
>        <name>hbase.regionserver.impl</name>
>        <value>org.apache.hadoop.hbase.regionserver.tableindexed.IndexedRegionServer</value>
>        <description>The implementation of the above interface</description>
>    </property>
> </configuration>
>
>
> --- On Mon, 1/4/10, stack <stack@duboce.net> wrote:
>
>> From: stack <stack@duboce.net>
>> Subject: Re: IO Exception on startup
>> To: hbase-user@hadoop.apache.org
>> Date: Monday, January 4, 2010, 1:19 AM
>> On Sun, Jan 3, 2010 at 1:08 AM, alaa
>> nobani <alaa_nobani@yahoo.com>
>> wrote:
>>
>> > Hi, Yes Hbase is working but our application which
>> uses hbase still not
>> > able to connect to hbase and gives the following error
>> on startup:
>> >
>> > 2010-01-03 02:56:41,809 INFO  [main]
>> > hbase.client.HConnectionManager$TableServers
>> (HConnectionManager.java:336) -
>> > getMaster attempt 7 of 10 failed; retrying after sleep
>> of 16000
>> > java.io.IOException:
>> >
>> org.apache.zookeeper.KeeperException$ConnectionLossException:
>> > KeeperErrorCode = ConnectionLoss for /hbase/master
>> >        at
>> >
>> org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper.readAddressOrThrow(ZooKeeperWrapper.java:331)
>> >        at
>> >
>> org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper.readMasterAddressOrThrow(ZooKeeperWrapper.java:240)
>> >        at
>> >
>> org.apache.hadoop.hbase.client.HConnectionManager$TableServers.getMaster(HConnectionManager.java:318)
>> >        at
>> >
>> org.apache.hadoop.hbase.client.HBaseAdmin.<init>(HBaseAdmin.java:72)
>> >
>> >
>> > Do you suggest anything may cause this exception ??
>> what we should look
>> > for?
>> >
>>
>> Looks like client machine is not able to connect to
>> zk.  It has an
>> hbase-site.xml w/ the proper zk ensemble members listed in
>> its CLASSPATH?
>>
>> St.Ack
>>
>>
>>
>>
>> >
>> > Thanks.
>> >
>> >
>> > --- On Thu, 12/31/09, Jean-Daniel Cryans <jdcryans@apache.org>
>> wrote:
>> >
>> > > From: Jean-Daniel Cryans <jdcryans@apache.org>
>> > > Subject: Re: IO Exception on startup
>> > > To: hbase-user@hadoop.apache.org
>> > > Date: Thursday, December 31, 2009, 9:16 PM
>> > > This exception happens normally in
>> > > the current release but it usually
>> > > doesn't appear on the command line. I cleaned it
>> up for the
>> > > next
>> > > release.
>> > >
>> > > HBase should still be working.
>> > >
>> > > J-D
>> > >
>> > > On Thu, Dec 31, 2009 at 1:36 AM, alaa nobani
>> <alaa_nobani@yahoo.com>
>> > > wrote:
>> > > > Zookeper is started , actually this
>> exception is
>> > > thrown after starting the master, here is the
>> complete
>> > > output i got when starting hbase:
>> > > >
>> > > > localhost: starting zookeeper, logging to
>> > >
>> >
>> /home/admo40/hbase-0.20.2/bin/../logs/hbase-admo40-zookeeper-mail.kalimat-maktoob.com.out
>> > > > starting master, logging to
>> > >
>> >
>> /home/admo40/hbase-0.20.2/bin/../logs/hbase-admo40-master-mail.kalimat-maktoob.com.out
>> > > > java.io.IOException:
>> > >
>> org.apache.zookeeper.KeeperException$NoNodeException:
>> > > KeeperErrorCode = NoNode for /hbase/master
>> > > >        at
>> > >
>> >
>> org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper.readAddressOrThrow(ZooKeeperWrapper.java:332)
>> > > >        at
>> > >
>> >
>> org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper.readAddress(ZooKeeperWrapper.java:318)
>> > > >        at
>> > >
>> >
>> org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper.readMasterAddress(ZooKeeperWrapper.java:250)
>> > > >        at
>> > >
>> >
>> org.apache.hadoop.hbase.master.ZKMasterAddressWatcher.waitForMasterAddressAvailability(ZKMasterAddressWatcher.java:82)
>> > > >        at
>> > >
>> >
>> org.apache.hadoop.hbase.master.HMaster.writeAddressToZooKeeper(HMaster.java:267)
>> > > >        at
>> > >
>> org.apache.hadoop.hbase.master.HMaster.<init>(HMaster.java:254)
>> > > >        at
>> > >
>> >
>> org.apache.hadoop.hbase.LocalHBaseCluster.<init>(LocalHBaseCluster.java:94)
>> > > >        at
>> > >
>> >
>> org.apache.hadoop.hbase.LocalHBaseCluster.<init>(LocalHBaseCluster.java:78)
>> > > >        at
>> > >
>> org.apache.hadoop.hbase.master.HMaster.doMain(HMaster.java:1214)
>> > > > localhost: starting regionserver, logging
>> to
>> > >
>> >
>> /home/admo40/hbase-0.20.2/bin/../logs/hbase-admo40-regionserver-mail.kalimat-maktoob.com.out
>> > > >
>> > > >
>> > > >
>> > > > --- On Thu, 12/31/09, Jeff Zhang <zjffdu@gmail.com>
>> > > wrote:
>> > > >
>> > > >> From: Jeff Zhang <zjffdu@gmail.com>
>> > > >> Subject: Re: IO Exception on startup
>> > > >> To: hbase-user@hadoop.apache.org
>> > > >> Date: Thursday, December 31, 2009, 11:18
>> AM
>> > > >> The zookeeper is not started ?
>> > > >>
>> > > >>
>> > > >> Jeff Zhang
>> > > >>
>> > > >>
>> > > >>
>> > > >> On Thu, Dec 31, 2009 at 12:33 AM, alaa
>> nobani
>> > > <alaa_nobani@yahoo.com>
>> > > >> wrote:
>> > > >>
>> > > >> > Hi,
>> > > >> > Any one can recognize the following
>> exception
>> > > am
>> > > >> getting when starting
>> > > >> > hbase and help me fix it:
>> > > >> >
>> > > >> > java.io.IOException:
>> > > >>
>> > >
>> org.apache.zookeeper.KeeperException$NoNodeException:
>> > > >> > KeeperErrorCode = NoNode for
>> /hbase/master
>> > > >> >        at
>> > > >> >
>> > > >>
>> > >
>> >
>> org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper.readAddressOrThrow(ZooKeeperWrapper.java:332)
>> > > >> >        at
>> > > >> >
>> > > >>
>> > >
>> >
>> org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper.readAddress(ZooKeeperWrapper.java:318)
>> > > >> >        at
>> > > >> >
>> > > >>
>> > >
>> >
>> org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper.readMasterAddress(ZooKeeperWrapper.java:250)
>> > > >> >        at
>> > > >> >
>> > > >>
>> > >
>> >
>> org.apache.hadoop.hbase.master.ZKMasterAddressWatcher.waitForMasterAddressAvailability(ZKMasterAddressWatcher.java:82)
>> > > >> >        at
>> > > >> >
>> > > >>
>> > >
>> >
>> org.apache.hadoop.hbase.master.HMaster.writeAddressToZooKeeper(HMaster.java:267)
>> > > >> >        at
>> > > >>
>> > >
>> org.apache.hadoop.hbase.master.HMaster.<init>(HMaster.java:254)
>> > > >> >        at
>> > > >> >
>> > > >>
>> > >
>> >
>> org.apache.hadoop.hbase.LocalHBaseCluster.<init>(LocalHBaseCluster.java:94)
>> > > >> >        at
>> > > >> >
>> > > >>
>> > >
>> >
>> org.apache.hadoop.hbase.LocalHBaseCluster.<init>(LocalHBaseCluster.java:78)
>> > > >> >        at
>> > > >>
>> > >
>> org.apache.hadoop.hbase.master.HMaster.doMain(HMaster.java:1214)
>> > > >> >
>> > > >> >
>> > > >> > Thanks.
>> > > >> >
>> > > >> >
>> > > >> >
>> > > >> >
>> > > >>
>> > > >
>> > > >
>> > > >
>> > > >
>> > >
>> >
>> >
>> >
>> >
>>
>
>
>
>

Mime
View raw message