hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Daniel Cryans <jdcry...@apache.org>
Subject Re: Can get HBase to work on RedHat, even though it works on Ubuntu
Date Fri, 29 Jan 2010 17:41:30 GMT
If you don't want HBase to start a zookeeper by default, edit
conf/hbase-env.sh and look towards the end of the file for the right
configuration to use.

To understand why the Master doesn't start, take a quick look at its
log you should see some obvious exceptions.

J-D

On Fri, Jan 29, 2010 at 9:37 AM, Pavel Gutin <pavelgutin@gmail.com> wrote:
> But that's the port zookeepers is running on. I want HBase to use that
> instance of zookeeper, and not start its own.
> I tried changing the port in zoo.cfg, and HBase started with no error.
> But then it still gave a "NoMasterRunningException"
>
> 2010/1/29 Jean-Daniel Cryans <jdcryans@apache.org>:
>> Something is already listening on the port Zookeeper is trying to
>> open. Make sure there's nothing listening on 2181, 2888 and 3888.
>>
>> J-D
>>
>> On Fri, Jan 29, 2010 at 9:18 AM, Pavel Gutin <pavelgutin@gmail.com> wrote:
>>> I apologize if I am breaking some kind of list etiquette, but I've
>>> been struggling for the last week, and I have no idea where to ask for
>>> help.
>>>
>>> I got HBase to work on my virtual Ubuntu machine, but when i tried
>>> moving it to RedHat running on real hardware, it fails. I start up
>>> hadoop, then zookeeper and when i start HBase, i get the following
>>> error:
>>>
>>>>$ bin/start-hbase.sh
>>> localhost: starting zookeeper, logging to
>>> /usr/local/hadoop/hbase/bin/../logs/hbase-hadoop-zookeeper-fchadoop04.out
>>> localhost: java.net.BindException: Address already in use
>>> localhost:      at sun.nio.ch.Net.bind(Native Method)
>>> localhost:      at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source)
>>> localhost:      at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)
>>> localhost:      at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)
>>> localhost:      at
>>> org.apache.zookeeper.server.NIOServerCnxn$Factory.<init>(NIOServerCnxn.java:140)
>>> localhost:      at
>>> org.apache.zookeeper.server.ZooKeeperServerMain.runFromConfig(ZooKeeperServerMain.java:106)
>>> localhost:      at
>>> org.apache.hadoop.hbase.zookeeper.HQuorumPeer.runZKServer(HQuorumPeer.java:90)
>>> localhost:      at
>>> org.apache.hadoop.hbase.zookeeper.HQuorumPeer.main(HQuorumPeer.java:75)
>>> starting master, logging to
>>> /usr/local/hadoop/hbase/bin/../logs/hbase-hadoop-master-fchadoop04.out
>>> localhost: starting regionserver, logging to
>>> /usr/local/hadoop/hbase/bin/../logs/hbase-hadoop-regionserver-fchadoop04.out
>>>
>>> When I go into the shell after that, doing anything throws a
>>> "MasterNotRunningException"
>>>
>>> I would appreciate any help.
>>>
>>>  - Pavel
>>>
>>
>

Mime
View raw message