hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adrian Popescu <popescuadrian2...@yahoo.com>
Subject Re: index creation problem in a fully distributed hbase
Date Tue, 26 Jan 2010 21:09:25 GMT
Thanks for the tip. Actually I realized that the code was working properly but it take some
time until the INDEX folder get visible on hadoop.

Does anyone know ways to improve the indexing speed by using map-reduce ? addIndex from IndexedTableAdmin
is quite expensive for large tables...

Thanks,
Adrian





________________________________
From: Jean-Daniel Cryans <jdcryans@apache.org>
To: hbase-user@hadoop.apache.org
Sent: Tue, January 26, 2010 7:38:14 PM
Subject: Re: index creation problem in a fully distributed hbase

Adrian,

If it doesn't throw any stack trace, you could try running jstack'ing
the process and see where the thread is stuck.

J-D

On Tue, Jan 26, 2010 at 9:58 AM, Adrian Popescu
<popescuadrian2001@yahoo.com> wrote:
> Hello All,
>
> I try to create some indexes in hbase with a code tested on a non-distributed installation.
The problem is that my application which builds the indexes hangs immediately after creating
partially the index: the .regioninfo file is created but not the actual index (__INDEX__ is
not populated at all). I guess that there is a setting that I miss somewhere on the fully
distributed installation but I don't know which. On the other hand I can load, scan tables
from the hbase, so hbase is working...
>
> Thank you,
> Adrian
>
>
>



      
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message