hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stack <st...@duboce.net>
Subject Re: Stargate sends HTTP error for rows that don't exist in Hbase table
Date Thu, 02 Sep 2010 23:58:58 GMT
I talked to Andrew.  404/405 is not an error.  its the way it works
when no such row (which makes sense to me given this is REST).  It
used to do nulls.  Thats when it was broke.

St.Ack

On Thu, Sep 2, 2010 at 4:40 PM, Sharma, Avani <agsharma@ebay.com> wrote:
> I think this problem could have happened because I did not stop stargate before upgrading
between hbase versions or before stopping hbase?
> Could that be the case? I still cannot recover from this error. Any Stargate experts
out there?
>
> -Avani
>
> -----Original Message-----
> From: Sharma, Avani [mailto:agsharma@ebay.com]
> Sent: Thursday, September 02, 2010 4:02 PM
> To: user@hbase.apache.org
> Subject: Stargate sends HTTP error for rows that don't exist in Hbase table
>
> I have been trying to look into stargate logs, but didn't find anything there or anywhere
else.
>
> Normally stargate would return a NULL value for a missing data row.
> Just like we see an empty value in Result after we do get() on a row that does not exist
in HBase table using the Java API.
>
> Stargate used to work just fine but lately I get 404 and 405 Http errors. Is there a
troubleshooting doc that I could look at?
>
> Example 1
> telnet <machine1> 8080
> Trying <ip1>...
> Connected to srwtnsdev02.smf.ebay.com (10.110.210.12).
> Escape character is '^]'.
> GET /table1/100
> <html>
> <head>
> <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"/>
> <title>Error 404 NOT_FOUND</title>
> </head>
> <body><h2>HTTP ERROR: 404</h2><pre>NOT_FOUND</pre>
> <p>RequestURI=/table1/100</p><p><i><small><a href="http://jetty.mortbay.org/">Powered
by Jetty://</a></small></i></p><br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
>
> </body>
> </html>
>
> Example 2
>
> Escape character is '^]'.
> GET /versio
> <html>
> <head>
> <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"/>
> <title>Error 405 METHOD_NOT_ALLOWED</title>
> </head>
> <body><h2>HTTP ERROR: 405</h2><pre>METHOD_NOT_ALLOWED</pre>
> <p>RequestURI=/versio</p><p><i><small><a href="http://jetty.mortbay.org/">Powered
by Jetty://</a></small></i></p><br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
> <br/>
>
> </body>
> </html>
> Connection closed by foreign host.
>
>
>
>

Mime
View raw message