hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcus Chou <chou.mar...@gmail.com>
Subject Re: Hbase setup on a single windows machine - running commands throws MasterNotRunningException
Date Thu, 02 Dec 2010 14:26:42 GMT
try /etc/hosts instead of direct IP address?

On 2 December 2010 22:14, Vijay <amirisetty.vijayaraghavan@gmail.com> wrote:

> Hi,
>    I am trying to setup HBase on a  single Windows Vista machine by
> following the instructions mentioned here :
> http://hbase.apache.org/docs/current/cygwin.html#Introduction
>
> I see the HBase server jvm starting up and listening to the default port of
> 60000.
>
> But when I launch a hbase shell (bin/hbase shell) and try a list command
> (list), I get the following error:
>
> *NativeException: org.apache.hadoop.hbase.MasterNotRunningException: null *
>
> I checked the hbase master logs, and see the following exception that I
> guess could be the problem
>
> 2010-12-02 19:34:11,809 WARN
> org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper: *Failed to create
> /hbase
> -- check quorum servers, currently=127.0.0.1:2181*
> org.apache.zookeeper.KeeperException$ConnectionLossException:
> KeeperErrorCode = ConnectionLoss for /hbase
> at org.apache.zookeeper.KeeperException.create(KeeperException.java:90)
>  at org.apache.zookeeper.KeeperException.create(KeeperException.java:42)
> at org.apache.zookeeper.ZooKeeper.exists(ZooKeeper.java:780)
>  at org.apache.zookeeper.ZooKeeper.exists(ZooKeeper.java:808)
> at
>
> org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper.ensureExists(ZooKeeperWrapper.java:405)
>  at
>
> org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper.ensureParentExists(ZooKeeperWrapper.java:432)
> at
>
> org.apache.hadoop.hbase.zookeeper.ZooKeeperWrapper.writeMasterAddress(ZooKeeperWrapper.java:520)
>  at
>
> org.apache.hadoop.hbase.master.HMaster.writeAddressToZooKeeper(HMaster.java:263)
> at org.apache.hadoop.hbase.master.HMaster.<init>(HMaster.java:245)
>  at
> org.apache.hadoop.hbase.LocalHBaseCluster.<init>(LocalHBaseCluster.java:94)
> at
> org.apache.hadoop.hbase.LocalHBaseCluster.<init>(LocalHBaseCluster.java:78)
>  at org.apache.hadoop.hbase.master.HMaster.doMain(HMaster.java:1229)
> at org.apache.hadoop.hbase.master.HMaster.main(HMaster.java:1274)
>
> From the configuration in hbase-default.xml, I guess that the zookeeper
> server must start and listen on port 2181
>
>  <property>
>    <name>hbase.zookeeper.quorum</name>
>    <value>127.0.0.1</value>
>    </description>
>  </property>
>
> This doesn't seem to be the case, and I see *no java process listening on
> port 2181*
>
> I also get the following message while starting hbase
> *: hostname nor servname provided, or not known*
>
> I am using HBase version 0.20.6
>
> Any suggestions / pointers would be of great help! I am open to trying out
> any suggestions.
>
> Thanks
> Vijay
>



-- 
Best regards,
Yue Zhou(Marcus),
System Research Group,
Parallel Processing Institute, Fudan University

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message