hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sun sf <revlet...@gmail.com>
Subject Re: Install problem - HBase 0.90.1 cannot connect to zookeeper
Date Thu, 24 Feb 2011 05:46:46 GMT
Thank you for your quick reply.

I know there are several different default configurations
between HBase0.90.1 and HBase0.20.6.

And so I tried pseudo and standalone install,
it seems both of them had the same zookeeper error.

In the standalone,I only added the root.dir to the hbase-site.xml
and not install hadoop.

I tried again and the error message turned to be
the following.

I attached the log file to make it more clear.
-----------------------------------------------------------------------------------------------------------------------
2011-02-23 15:09:46,980 INFO org.apache.zookeeper.ClientCnxn: Opening socket
connection to server localhost/192.168.70.5:2181
2011-02-23 15:09:46,981 WARN org.apache.zookeeper.ClientCnxn: Session
0x12e54c8de7f0001 for server null, unexpected error, closing socket
connection and attempting reconnect
java.net.ConnectException: Connection refused
    at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
    at
sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567)
    at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1119)
2011-02-23 15:09:46,986 INFO org.apache.zookeeper.ClientCnxn: Opening socket
connection to server localhost/192.168.70.5:2181
2011-02-23 15:09:46,987 WARN org.apache.zookeeper.ClientCnxn: Session
0x12e54c8de7f0002 for server null, unexpected error, closing socket
connection and attempting reconnect
java.net.ConnectException: Connection refused
    at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
    at
sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567)
    at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1119)
-----------------------------------------------------------------------------------------------------------------------


On Thu, Feb 24, 2011 at 2:33 PM, Stack <stack@duboce.net> wrote:

> On Wed, Feb 23, 2011 at 9:08 PM, sun sf <revletter@gmail.com> wrote:
> >
> ----------------------------------------------------------------------------------------
> > org.apache.haddop.hase.zookeeper.MiniZookeeperCluster
> > Server localhost:2181 not up java.net.NoRouteToHostException
> > No route to host MinizookeeperCluster.java 1221
>
> Your networking on that machine is borked when it says
> NoRouteToHostException.  Poke around in the logs.  Its probably trying
> to connect to localhost or whatever its finding for hostname on this
> machine.  Trying doing same with telnet.  You'll probably run into the
> NoRouteToHost message.  Fix it first.
>
> Be careful using same config. for 0.90.1 as you used for 0.20.6.  The
> default values have changed as has how you do config. for zookeeper.
> Start with 0.90.1 defaults and change one at a time.   Go by the
> documentation, here http://hbase.apache.org/notsoquick.html, to be
> sure.
>
> Hope this helps,
> St.Ack
>

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message