hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stack <st...@duboce.net>
Subject Re: Question about Thrift when upgrading from Hbase .20.6 to .90.3
Date Thu, 23 Jun 2011 04:30:00 GMT
Andy:

Please see http://hbase.apache.org/book/hadoop.html for our hadoop
versions story.

St.Ack

On Wed, Jun 22, 2011 at 9:00 PM, Zhong, Andy <Sheng.Zhong@searshc.com> wrote:
>
> Karl,
>
> Sorry but could you let me know which hadoop version is being used, and
> any compatible issue? It seems Hbase 0.90.2 and 0.90.3 are compatible
> only on 0.20-append only.
>
> Thanks,
> Andy Zhong
>
>
>
> -----Original Message-----
> From: Karl Kuntz [mailto:kkuntz@tradebotsystems.com]
> Sent: Wednesday, June 22, 2011 1:59 PM
> To: user@hbase.apache.org
> Subject: Question about Thrift when upgrading from Hbase .20.6 to .90.3
>
> Current version .20.6
> Upgrade target 90.3
>
> So Hbase .20.6 uses Thrift .2 and Hbase .90.3 makes use of Thrift .5.
> We currently use the supplied ThriftServer in Hbase.
>
> In my initial testing for the upgrade, I've not seen any issues using
> code that was generated/compiled against the earlier versions of
> hbase/thrift and simply pointing them at the latest ThriftServer
> supplied with .90.3 I don't see thrift mentioned specifically in the
> upgrade topic in the book, and couldn't find any directly related topics
> on the mailing list, so I would like to just verify this is the expected
> result.
>
> Am I missing something subtle that could cause issues later?
>
> Would updating client code to use Thrift .5 provide a performance (or
> some other nice) improvement?
>
> Thanks,
>
> -Karl
>
>
>

Mime
View raw message