hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Daniel Cryans <jdcry...@apache.org>
Subject Re: HMaster issues
Date Thu, 20 Oct 2011 18:28:22 GMT
The client will pick it up like any other HBase process ran with bin/
scripts, so this would point to a configuration error. Make sure your client
is really picking up the config file you think it is, that there's no typo
in the file, that sort of stuff.

J-D

On Thu, Oct 20, 2011 at 11:15 AM, Ben West <bwsithspawn00@yahoo.com> wrote:

> You're right:
>
> 11/10/18 15:39:54 INFO zookeeper.ZooKeeper: Initiating client connection,
> connectString=localhost:2181 sessionTimeout=180000
> watcher=hconnection
>
>
> How can I configure the port? It's set in my hbase-site.xml file correctly.
>
>
>
> ----- Original Message -----
> From: Jean-Daniel Cryans <jdcryans@apache.org>
> To: user@hbase.apache.org; Ben West <bwsithspawn00@yahoo.com>
> Cc:
> Sent: Tuesday, October 18, 2011 1:23 PM
> Subject: Re: HMaster issues
>
> This line:
>
> java.lang.NoSuchMethodException:
>
> org.apache.hadoop.fs.ChecksumFileSystem$ChecksumFSInputChecker.getFileLength()
>
> Is because it's using the local filesystem and not HDFS (so it's expected).
>
> As far as I can tell the master starts ok, maybe the client is trying to
> use
> the ZK port 2181? Start the shell with -d and it should show you where it's
> connecting.
>
> J-D
>
> On Tue, Oct 18, 2011 at 7:19 AM, Ben West <bwsithspawn00@yahoo.com> wrote:
>
> > Hey All,
> >
> > I'm having an issue I can't debug. The shell gives me a
> > MasterNotRunningException, but I can connect to the master via the web
> > interface. I'm using the Cloudera demo VM, which has a standalone
> instance
> > of HBase.
> >
> > I'm attaching the HBase-master log file. The only thing I can see is a
> > warning that getting a checksum failed, but from the warning that doesn't
> > sound very serious.
> >
> > The only thing in my config file is to change the Zookeeper port since
> > there seemed to be a conflict with the default.
> >
> > Any help would be appreciated,
> > -Ben
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message