hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitriy Lyubimov <dlie...@gmail.com>
Subject Re: Table region got stuck, doesn't move/assign
Date Mon, 16 Jan 2012 23:46:52 GMT
Another weirdness, where it all started while that regions was still
where it was, was that any attempt to query that table caused
indefinite hanging (call never returned). Now of course that we
killed/restarted the RS it just says 'region not serving'.

On Mon, Jan 16, 2012 at 3:45 PM, Dmitriy Lyubimov <dlieu.7@gmail.com> wrote:
> Hi,
>
> i have a table which seems to get stuck in a state where it can't be
> queried, moved or split/compacted.
>
> The logs don't have any error statements. Our admin tried hbck to no avail .
>
> We stopped the region server, table did not get reassigned. (all other
> did). when bround in UI, this table just showed "region server
> offline". (??? shouldn't get reassigned as others did?)
>
> Brining region server online loaded it with other regions, but not
> that table. master apparently still thinks it is on that node (data6)
> and so all requests are failing with region not serving message.
>
> assign/move/ unassign commands have no effect (move fails, but
> assing/unassign seems to be quiet with no apparent effect).
>
> Another weirdness: it's the only table that is showing up under
> hbase/table in zk and its region is listed under /hbase/unassigned.
>
>
> What else can we do? this is a prod database (cdh3u0 ) and we pretty
> much like to avoid any down time.
>
> Where can i read about meaning and transitions of zookeeper nodes under /hbase ?
>
> Thank you very much.
> -d

Mime
View raw message