hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bai Shen <baishen.li...@gmail.com>
Subject Re: hbase.client.scanner.timeout.period not being respected
Date Mon, 22 Oct 2012 15:12:04 GMT
I'll give that a try, but I don't recall getting any LeaseExceptions.  All
of the ones I saw were ScannerTimeoutExceptions.

On Mon, Oct 22, 2012 at 11:02 AM, Victor Jerlin <victor@acuitsys.com> wrote:

> Hi,
>
> Try setting hbase.rpc.timeout in the client.
>
> More info here in #12.5.2:
> http://hbase.apache.org/book/trouble.client.html
>
> /Victor
>
>
> 2012/10/22 Bai Shen <baishen.lists@gmail.com>
>
>> No, I'm not.  I tried changing it to hbase.regionserver.lease.period, but
>> that's not being picked up either.
>>
>> What is the proper setting for modifying the timeout period?  I keep
>> getting ScannerTimeoutExceptions.
>>
>> Thanks.
>>
>> On Fri, Oct 19, 2012 at 12:17 PM, Jean-Daniel Cryans <jdcryans@apache.org
>> >wrote:
>>
>> > That config is only available in trunk (per
>> > https://issues.apache.org/jira/browse/HBASE-6170), are you using a
>> > trunk snapshot?
>> >
>> > J-D
>> >
>> > On Thu, Oct 18, 2012 at 8:25 AM, Bai Shen <baishen.lists@gmail.com>
>> wrote:
>> > > I've set hbase.client.scanner.timeout.period on my client to 300000,
>> but
>> > > I'm still getting errors showing that hbase is using the default
>> value of
>> > > 60000.
>> > >
>> > > Any ideas why this is?
>> > >
>> > > Thanks.
>> >
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message