hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ameya Kantikar <am...@groupon.com>
Subject Re: Region stuck in transition
Date Fri, 12 Apr 2013 15:31:36 GMT
We have faced similar issue before (We are on 0.94.2), the way I resolved
this is by doing this:

in hbase shell,

assign region_name

Hope this works for you.




On Fri, Apr 12, 2013 at 8:22 AM, Ted Yu <yuzhihong@gmail.com> wrote:

> Can you pastebin master log ?
>
> What version of hbase are you using ?
>
> Thanks
>
> On Apr 12, 2013, at 5:50 AM, Fabien Chung <chung.fabien@gmail.com> wrote:
>
> > Hello,
> >
> > I'm  facing some troubles and I don't knwo how to figure out. The master
> > hbase crashed couple days ago. I restarted it, but until now, the -ROOT-
> region
> > is stucked in transition.
> > I tried to restart the service, delete it/ remove all the file in habse
> > folder. But the regions still is in transition.
> >
> > Do you have an idea why ?
> >
> >
> > *Edit : I tried as well to create the service on another node, but the
> > result is still the same : region in transition for a while.*
> >
> >
> > Regards
> >
> >
> > 2013/4/12 Fabien Chung <fabien.chung@ysance.com>
> >
> >> Hello,
> >>
> >> I'm  facing some troubles and I don't knwo how to figure out. The master
> >> hbase crashed couple days ago. I restarted it, but until now, the
> -ROOT- region
> >> is stucked in transition.
> >> I tried to restart the service, delete it/ remove all the file in habse
> >> folder. But the regions still is in transition.
> >>
> >> Do you have an idea why ?
> >>
> >> Regards
> >>
> >> --
> >> *CHUNG Fabien
> >>
> >> *
> >
> >
> >
> > --
> > Chung Fabien
> >
> >
> >
> > EFREI Promo 2013
> > Tel : 06 48 03 54 92
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message