hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Marc Spaggiari <jean-m...@spaggiari.org>
Subject Re: HBase shell does not start
Date Sat, 06 Apr 2013 00:37:42 GMT
Hi Chris,

How are you getting that?

So you installed HBase, have started it, and then tried to launch
hbase shell? You are getting this error when the shell is starting? Or
while executing a specific command?


2013/4/5 Christoph Pilka <christoph.pilka@googlemail.com>:
> Hi all,
> Anyone has an idea what's going wrong here? I've downloaded the HBase tarball,
installed HBase on my Mac OS X 10.8 box but get always the same error launching the hbase
> NoMethodError: undefined method `getTerminal' for Java::Jline::Terminal:Module
> refresh_width at /usr/local/hbase-
> initialize at /usr/local/hbase-
> It's the same with the Homebrew prepackaged version of HBase ...
> I'm running
> java version "1.7.0_17"
> Java(TM) SE Runtime Environment (build 1.7.0_17-b02)
> Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)
> Many thanks in advance!
> Cheerio, Chris

View raw message