hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "S. Zhou" <myx...@yahoo.com>
Subject Re: HBase mapreduce job: unable to find region for a table
Date Thu, 11 Jul 2013 18:42:00 GMT
Yes, I can see the table through hbase shell and web ui (localhost:60010). hbck reports ok

 From: Jean-Marc Spaggiari <jean-marc@spaggiari.org>
To: user@hbase.apache.org; S. Zhou <myxjtu@yahoo.com> 
Sent: Thursday, July 11, 2013 11:01 AM
Subject: Re: HBase mapreduce job: unable to find region for a table


Is your table properly served? Are you able to see it on the Web UI? Is you HBCK reporting
everything correctly?


2013/7/11 S. Zhou <myxjtu@yahoo.com>

I am running a very simple MR HBase job (reading from a tiny HBase table and outputs nothing).
I run it on a pseudo-distributed HBase cluster on my local machine which uses a pseudo-distributed
HDFS (on local machine again). When I run it, I get the following exception: Unable to find
region for test. But I am sure the table "test" exists.
>13/07/11 10:27:35 INFO zookeeper.ClientCnxn: Session establishment complete on server
localhost/, sessionid = 0x13fcec598d70005, negotiated timeout = 90000
>13/07/11 10:38:15 ERROR mapreduce.TableInputFormat: org.apache.hadoop.hbase.client.NoServerForRegionException:
Unable to find region for test,,99999999999999 after 10 tries.
>    at org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation.locateRegionInMeta(HConnectionManager.java:980)
>    at org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation.locateRegion(HConnectionManager.java:885)
>    at org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation.locateRegionInMeta(HConnectionManager.java:987)
>    at org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation.locateRegion(HConnectionManager.java:889)
>    at org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation.locateRegion(HConnectionManager.java:846)
>    at org.apache.hadoop.hbase.client.HTable.finishSetup(HTable.java:234)
>  .....
>Here is my HBase hbase-site.xml file:
>  <property>
>    <name>hbase.rootdir</name>
>    <value>hdfs://</value>
>  </property>
>  <property>
>    <name>hbase.cluster.distributed</name>
>    <value>true</value>
>  </property>
> <property>
>    <name>hbase.zookeeper.quorum</name>
>    <value></value>
>  </property>
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message