hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pavan Sudheendra <pavan0...@gmail.com>
Subject Re: Trying to run HBase in standalone and not able to access Java API! Desperate help needed.
Date Tue, 16 Jul 2013 11:59:18 GMT
Yes Jean, It is working fine.
@Rohit, i thought in the standalone mode it is not required.

On Tue, Jul 16, 2013 at 5:25 PM, Rohit Kelkar <rohitkelkar@gmail.com> wrote:
> In your client code can you try explicitly setting values of
> hbase.zookeeper.quorum
>
> - R
>
> On Tuesday, July 16, 2013, Jean-Marc Spaggiari wrote:
>
>> Hi Pavan,
>>
>> You should try to avoid localhost. Try to prefers your host name. Is
>> http://ubuntu:60010/master-status?filter=all<
>> http://localhost:60010/master-status?filter=all>working
>> fine?
>>
>> JM
>>
>> 2013/7/16 Pavan Sudheendra <pavan0591@gmail.com>
>>
>> > Hi all,
>> > I further went to http://localhost:60010/master-status?filter=all and
>> > checked that:
>> > [{"statustimems":-1,"status":"Waiting for a
>> > call","starttimems":1373948304755,"description":"REPL IPC Server
>> > handler 2 on
>> >
>> 38039","state":"WAITING","statetimems":-1},{"statustimems":-1,"status":"Waiting
>> > for a call","starttimems":1373948304755,"description":"REPL IPC Server
>> > handler 1 on
>> >
>> 38039","state":"WAITING","statetimems":-1},{"statustimems":-1,"status":"Waiting
>> > for a call","starttimems":1373948304755,"description":"REPL IPC Server
>> > handler 0 on 38039","state":"WAITING","statetimems":-1},
>> >
>> > all the rpc calls gets stuck on waiting.. and my master it says active
>> > on the tasks page for a while and dissapears. Any help much
>> > appreciated.
>> >
>> > On Tue, Jul 16, 2013 at 8:54 AM, Pavan Sudheendra <pavan0591@gmail.com>
>> > wrote:
>> > > @Kim how is that possible? I'm using the stable release.
>> > >
>> > > On Tue, Jul 16, 2013 at 8:37 AM, Pavan Sudheendra <pavan0591@gmail.com
>> >
>> > wrote:
>> > >> @Jean, Nope, it didn't work. I even re-installed hbase.
>> > >>
>> > >> Has anyone worked with the Hbase-The definitive guide examples with
>> > >> standalone mode?
>> > >>
>> > >> On Mon, Jul 15, 2013 at 10:06 PM, Kim Chew <kchew534@gmail.com>
>> wrote:
>> > >>> Another thing is,
>> > >>>
>> > >>> 2013-07-15 05:15:58,764 WARN org.apache.hadoop.ipc.
>> > >>> HBaseServer:
>> > >>> Incorrect header or version mismatch from 127.0.0.1:46149 got
>> version
>> > >>> 47 expected version 3
>> > >>>
>> > >>> Seems like you are using different versions of HBase when compiling
>> > your
>> > >>> codes.
>> > >>>
>> > >>> Kim
>> > >>>
>> > >>>
>> > >>>
>> > >>> On Mon, Jul 15, 2013 at 5:40 AM, Jean-Marc Spaggiari <
>> > >>> jean-marc@spaggiari.org> wrote:
>> > >>>
>> > >>>> You should change our hosts file to something like that:
>> > >>>>
>> > >>>> 127.0.0.1 localhost
>> > >>>> 192.168.XXX.YYY ubuntu.ubuntu-domain ubuntu
>> > >>>>
>> > >>>> Where 192.168.XXX.YYY is your local host IP address
>> > >>>>
>> > >>>> Can you change and retry? (Restart).
>> > >>>>
>> > >>>> JM
>> > >>>>
>> > >>>> 2013/7/15 Pavan Sudheendra <pavan0591@gmail.com>
>> > >>>>
>> > >>>> > The fact of the matter is i'm able to anything in the
shell. It
>> > works
>> > >>>> > fine, but i'm not able to execute normal CRUD operations
with the
>> > JAVA
>> > >>>> > API programatically.
>> > >>>> >
>> > >>>> > On Mon, Jul 15, 2013 at 5:48 PM, Pavan Sudheendra <
>> > pavan0591@gmail.com>
>> > >>>> > wrote:
>> > >>>> > > Hi Jean,
>> > >>>> > > Here is my /etc/hosts/
>> > >>>> > >
>> > >>>> > > 127.0.0.1 localhost
>> > >>>> > > 127.0.0.1 ubuntu
>> > >>>> > > 127.0.0.1 ubuntu.ubuntu-domain ubuntu
>> > >>>> > >
>> > >>>> > > Yes i went to http://localhost:60010 and saw that
my master is
>> > running
>>



-- 
Regards-
Pavan

Mime
View raw message