hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Compile error when running map-reduce program for HBase Export
Date Sun, 03 Nov 2013 04:40:33 GMT
The fourth parameter should be of type Class. 

On Nov 2, 2013, at 8:58 PM, Bharat Shetty <bharat.shetty@gmail.com> wrote:

> Hi,
> I'm trying to export data from HBase table into HDFS using map-reduce in
> the Text format. Note that I have already tried the export tool that comes
> with HBase, which dumps data into the HDFS as bytes in a sequence file.
> However, my use-case requires Text data to be dumped into the HDFS.
> I'm running into compile time errors when I run my Java program.
> bsb@naples:~javac -classpath $HBASE_CLASSPATH HBaseCsvExporter.java
> HBaseCsvExporter.java:80: cannot find symbol
> symbol  : variable Text
> location: class HBaseCsvExporter
> TableMapReduceUtil.initTableMapperJob(tableName, s, Exporter.class, Text,
> Text, job);
>                                                                    ^
> HBaseCsvExporter.java:80: cannot find symbol
> The error indicates that my Java program cannot find location of the "Text"
> class. I tried including many jars that came in lib/ folder of the
> HBase-0.96. Which jar I may be missing in the HBASE_CLASSPATH ? Note, that
> I'm using HBase-0.96 with Hadoop-2.1.0-beta.
> If someone could throw more light on how to solve this, it would help
> greatly.
> Regards,
> Bharat Shetty Barkur

View raw message