hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: YCSB load data stucked
Date Tue, 21 Oct 2014 09:37:36 GMT
Cycling bits:
http://search-hadoop.com/m/DHED4N0syk1

Andrew has his ycsb repo as well. 

Cheers

On Oct 21, 2014, at 2:28 AM, Qiang Tian <tianq01@gmail.com> wrote:

> Hi Guys,
> I am running YCSB 0.1.4 against hbase 0.98.5,
> 
> "bin/ycsb load hbase -P workloads/workloada -p columnfamily=f1 -p
> recordcount=1000 -p threadcount=4 -s | tee -a workloada.dat" stucked as
> below:
> 
> 10 sec: 0 operations;
> 20 sec: 0 operations;
> 30 sec: 0 operations;
> 40 sec: 0 operations;
> 50 sec: 0 operations;
> ...
> 
> stacktrace shows YCSB is locating meta region:
> 
> at java/lang/Object.wait(Object.java:201)
> at
> org/apache/hadoop/hbase/zookeeper/ZooKeeperNodeTracker.blockUntilAvailable(ZooKeeperNodeTracker.java:122)
> (entered lock:
> org/apache/hadoop/hbase/zookeeper/RootRegionTracker@0x00000000E01A02B0,
> entry count: 1)
> at
> org/apache/hadoop/hbase/zookeeper/RootRegionTracker.waitRootRegionLocation(RootRegionTracker.java:73)
> at
> org/apache/hadoop/hbase/client/HConnectionManager$HConnectionImplementation.locateRegion(HConnectionManager.java:786)
> at
> org/apache/hadoop/hbase/client/HConnectionManager$HConnectionImplementation.locateRegion(HConnectionManager.java:766)
> at
> org/apache/hadoop/hbase/client/HConnectionManager$HConnectionImplementation.locateRegionInMeta(HConnectionManager.java:895)
> at
> org/apache/hadoop/hbase/client/HConnectionManager$HConnectionImplementation.locateRegion(HConnectionManager.java:797)
> at
> org/apache/hadoop/hbase/client/HConnectionManager$HConnectionImplementation.locateRegion(HConnectionManager.java:766)
> at
> org/apache/hadoop/hbase/client/HConnectionManager$HConnectionImplementation.locateRegionInMeta(HConnectionManager.java:895)
> at
> org/apache/hadoop/hbase/client/HConnectionManager$HConnectionImplementation.locateRegion(HConnectionManager.java:801)
> at
> org/apache/hadoop/hbase/client/HConnectionManager$HConnectionImplementation.locateRegion(HConnectionManager.java:766)
> at org/apache/hadoop/hbase/client/HTable.<init>(HTable.java:189)
> at org/apache/hadoop/hbase/client/HTable.<init>(HTable.java:163)
> at com/yahoo/ycsb/db/HBaseClient.getHTable(HBaseClient.java:111)
> (entered lock: java/lang/Object@0x00000000E006AD20, entry count: 1)
> at com/yahoo/ycsb/db/HBaseClient.update(HBaseClient.java:295)
> at com/yahoo/ycsb/db/HBaseClient.insert(HBaseClient.java:350)
> at com/yahoo/ycsb/DBWrapper.insert(DBWrapper.java:145)
> at com/yahoo/ycsb/workloads/CoreWorkload.doInsert(CoreWorkload.java:461)
> at com/yahoo/ycsb/ClientThread.run(Client.java:269)
> 
> 
> however looking at the RS log, the meta region is up successfully, hbase
> shell works fine. I can also see it in zk cli:
> 
> [zk: localhost:2181(CONNECTED) 2] get /hbase/meta-region-server
> ?regionserver:60020??|~md"PBUF
> 
> ihc028???????)
> cZxid = 0xc57
> ctime = Tue Oct 21 16:23:41 CST 2014
> mZxid = 0xc57
> mtime = Tue Oct 21 16:23:41 CST 2014
> pZxid = 0xc57
> cversion = 0
> dataVersion = 0
> aclVersion = 0
> ephemeralOwner = 0x0
> dataLength = 71
> numChildren = 0
> 
> 
> is it a configure issue? anything wrong with my steps?
> 1. on hbase master node, download ycsb-0.1.4.tar.gz
> 2. copy all jars in hbase lib dir to hbase-binding/lib
> 3. copy hbase-site.xml to hbase-binding/conf
> 4. create table in hbase shell: create 'usertable','f1','f2','f3'
> 5. load data via above command.
> 
> thanks.

Mime
  • Unnamed multipart/alternative (inline, 7-Bit, 0 bytes)
View raw message